What’s Vulnerable › Vulnerabilities
CVE-2024-2952: Server-Side Template Injection in BerriAI/litellm
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-76
Description
BerriAI/litellm is vulnerable to Server-Side Template Injection (SSTI) via the `/completions` endpoint. The vulnerability arises from the `hf_chat_template` method processing the `chat_template` parameter from the `tokenizer_config.json` file through the Jinja template engine without proper sanitization. Attackers can exploit this by crafting malicious `tokenizer_config.json` files that execute arbitrary code on the server.
Affected products
- BerriAI litellm: before 1.34.42 — fixed in 1.34.42
How to fix
Upgrade to a fixed version: BerriAI litellm 1.34.42. Check the vendor advisory for mitigations.
References
- https://github.com/berriai/litellm/commit/8a1cdc901708b07b7ff4eca20f9cb0f1f0e8d0b3
- https://huntr.com/bounties/a9e0a164-6de0-43a4-a640-0cbfb54220a4
- https://github.com/berriai/litellm/commit/8a1cdc901708b07b7ff4eca20f9cb0f1f0e8d0b3
- https://huntr.com/bounties/a9e0a164-6de0-43a4-a640-0cbfb54220a4
Get alerted when CVE-2024-2952 or the next vulnerability affects your stack