What’s Vulnerable › Vulnerabilities
CVE-2024-2966: Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) <= 5.5.6 - Sensitive Information Exposure via element_pack_ajax_search
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-200
Description
The Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.5.6 via the element_pack_ajax_search function. This makes it possible for unauthenticated attackers to extract sensitive data including password protected post details.
Affected products
- bdthemes Element Pack – Widgets, Templates & Addons for Elementor: before 5.6.0 — fixed in 5.6.0
How to fix
Upgrade to a fixed version: bdthemes Element Pack – Widgets, Templates & Addons for Elementor 5.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3066178/bdthemes-element-pack-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39e0fd33-4071-4510-a7d5-b499a8a3543c?source=cve
- https://plugins.trac.wordpress.org/changeset/3066178/bdthemes-element-pack-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/39e0fd33-4071-4510-a7d5-b499a8a3543c?source=cve
Get alerted when CVE-2024-2966 or the next vulnerability affects your stack