What’s Vulnerable › Vulnerabilities
CVE-2024-29733: Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-21 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Airflow FTP provider: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow FTP provider 3.7.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/19/3
- https://docs.python.org/3/library/ssl.html#best-defaults
- https://github.com/apache/airflow/blob/95e26118b828c364755f3a8c96870f3591b01c31/airflow/providers/ftp/hooks/ftp.py#L280
- https://github.com/apache/airflow/pull/38266
- https://lists.apache.org/thread/265t5zbmtjs6h9fkw52wtp03nsbplky2
- http://www.openwall.com/lists/oss-security/2024/04/19/3
- https://docs.python.org/3/library/ssl.html#best-defaults
- https://github.com/apache/airflow/blob/95e26118b828c364755f3a8c96870f3591b01c31/airflow/providers/ftp/hooks/ftp.py#L280
- https://github.com/apache/airflow/pull/38266
- https://lists.apache.org/thread/265t5zbmtjs6h9fkw52wtp03nsbplky2
Get alerted when CVE-2024-29733 or the next vulnerability affects your stack