What’s Vulnerable › Vulnerabilities
CVE-2024-29736: Apache CXF: SSRF vulnerability via WADL stylesheet parameter
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-918
Description
A SSRF vulnerability in WADL service description in versions of Apache CXF before 4.0.5, 3.6.4 and 3.5.9 allows an attacker to perform SSRF style attacks on REST webservices. The attack only applies if a custom stylesheet parameter is configured.
Affected products
- Apache Software Foundation Apache CXF: before 3.5.9; from 3.6.0 before 3.6.4; from 4.0.0 before 4.0.5 — fixed in 3.5.9, 3.6.4, 4.0.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 3.5.9, 3.6.4, 4.0.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4jtpsswn2r6xommol54p5mg263ysgdw2
- http://www.openwall.com/lists/oss-security/2024/07/18/2
- https://lists.apache.org/thread/4jtpsswn2r6xommol54p5mg263ysgdw2
- https://security.netapp.com/advisory/ntap-20241115-0003/
Get alerted when CVE-2024-29736 or the next vulnerability affects your stack