What’s Vulnerable › Vulnerabilities
CVE-2024-29737: Apache StreamPark (incubating): maven build params could trigger remote command execution
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-77
Description
In streampark, the project module integrates Maven's compilation capabilities. The input parameter validation is not strict, allowing attackers to insert commands for remote command execution, The prerequisite for a successful attack is that the user needs to log in to the streampark system and have system-level permissions. Generally, only users of that system have the authorization to log in, and users would not manually input a dangerous operation command. Therefore, the risk level of this vulnerability is very low. Mitigation: all users should upgrade to 2.1.4 Background info: Log in to Streampark using the default username (e.g. test1, test2, test3) and the default password (streampark). Navigate to the Project module, then add a new project. Enter the git repository address of the project and input `touch /tmp/success_2.1.2` as the "Build Argument". Note that there is no verification and interception of the special character "`". As a result, you will find that this injection command will be successfully executed after executing the build. In the latest version, the special symbol ` is intercepted.
Affected products
- Apache Software Foundation Apache StreamPark: from 2.0.0 before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPark 2.1.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/07/17/2
- https://lists.apache.org/thread/xhx7jt1t24s6d7o435wxng8t0ojfbfh5
- http://www.openwall.com/lists/oss-security/2024/07/17/2
- https://lists.apache.org/thread/xhx7jt1t24s6d7o435wxng8t0ojfbfh5
Get alerted when CVE-2024-29737 or the next vulnerability affects your stack