What’s Vulnerable › Vulnerabilities
CVE-2024-2975
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-1223
Description
A race condition was identified through which privilege escalation was possible in certain configurations.
Affected products
- Octopus Deploy Octopus Server: from 0.9 before 2023.4.8432; from 2024.1.437 before 2024.1.12087; from 2024.2.101 before 2024.2.2075 — fixed in 2023.4.8432, 2024.1.12087, 2024.2.2075
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2023.4.8432, 2024.1.12087, 2024.2.2075. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2024/sa2024-01/
- https://advisories.octopus.com/post/2024/sa2024-01/
Get alerted when CVE-2024-2975 or the next vulnerability affects your stack