What’s Vulnerable › Vulnerabilities
CVE-2024-29818: WordPress WP Poll Maker plugin <= 3.1 - Authenticated Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Poll Maker & Voting Plugin Team (InfoTheme) WP Poll Maker allows Stored XSS.This issue affects WP Poll Maker: from n/a through 3.1.
Affected products
- Poll Maker & Voting Plugin Team (InfoTheme) WP Poll Maker: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: Poll Maker & Voting Plugin Team (InfoTheme) WP Poll Maker 3.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/epoll-wp-voting/wordpress-wp-poll-maker-plugin-3-1-authenticated-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/epoll-wp-voting/wordpress-wp-poll-maker-plugin-3-1-authenticated-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29818 or the next vulnerability affects your stack