What’s Vulnerable › Vulnerabilities
CVE-2024-29831: Apache DolphinScheduler: RCE by arbitrary js execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server. If you are using the switch task plugin, please upgrade to version 3.2.2.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/x1ch0x5om3srtbnp7rtsvdszho3mdrq0
- http://www.openwall.com/lists/oss-security/2024/08/09/6
Get alerted when CVE-2024-29831 or the next vulnerability affects your stack