What’s Vulnerable › Vulnerabilities
CVE-2024-29833: WordPress Photo Gallery Plugin <= 1.8.21 Stored Cross Site Scripting in UploadHandler
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The image upload component allows SVG files and the regular expression used to remove script tags can be bypassed by using a Cross Site Scripting payload which does not match the regular expression; one example of this is the inclusion of whitespace within the script tag. An attacker must target an authenticated user with permissions to access this feature, however once uploaded the payload is also accessible to unauthenticated users.
Affected products
- 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery: before 1.8.22 — fixed in 1.8.22
How to fix
Upgrade to a fixed version: 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery 1.8.22. Check the vendor advisory for mitigations.
References
- https://appcheck-ng.com/xss-vulnerabilities-discovered-10web-photogallery-wordpress-plugin/
- https://wordpress.org/plugins/photo-gallery/#developers
- https://appcheck-ng.com/xss-vulnerabilities-discovered-10web-photogallery-wordpress-plugin/
- https://wordpress.org/plugins/photo-gallery/#developers
Get alerted when CVE-2024-29833 or the next vulnerability affects your stack