What’s Vulnerable › Vulnerabilities
CVE-2024-29864
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-77
Description
Distrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
Affected products
- 89Luca89 Distrobox: before 1.7.0.1 — fixed in 1.7.0.1
How to fix
Upgrade to a fixed version: 89Luca89 Distrobox 1.7.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/89luca89/distrobox/commit/82a69f0a234e73e447d0ea8c8b3443b84fd31944
- https://github.com/89luca89/distrobox/issues/1275
- https://github.com/89luca89/distrobox/commit/82a69f0a234e73e447d0ea8c8b3443b84fd31944
- https://github.com/89luca89/distrobox/issues/1275
Get alerted when CVE-2024-29864 or the next vulnerability affects your stack