What’s Vulnerable › Vulnerabilities
CVE-2024-29869: Apache Hive: Credentials file created with non restrictive permissions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-28 · updated 2026-06-17
- Weakness: CWE-732
Description
Hive creates a credentials file to a temporary directory in the file system with permissions 644 by default when the file permissions are not set explicitly. Any unauthorized user having access to the directory can read the sensitive information written into this file. Users are recommended to upgrade to version 4.0.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache Hive: from 1.1.0 before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Hive 4.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/hive
- https://github.com/apache/hive/commit/20106e254527f7d71b2e34455c4322e14950c620
- https://issues.apache.org/jira/browse/HIVE-28134
- https://lists.apache.org/thread/h27ohpyrqf9w1m3c0tqr7x8jg59rcrv6
- http://www.openwall.com/lists/oss-security/2025/01/28/4
Get alerted when CVE-2024-29869 or the next vulnerability affects your stack