What’s Vulnerable › Vulnerabilities
CVE-2024-29887: Serverpod client accepts any certificate
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-295
Description
Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the `serverpod_client` package. Making them susceptible to a man in the middle attack against encrypted traffic between the client device and the server. An attacker would need to be able to intercept the traffic and highjack the connection to the server for this vulnerability to be used. Upgrading to version `1.2.6` resolves this issue.
Affected products
- serverpod: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: serverpod 1.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/serverpod/serverpod/commit/d55bf8d12967fc7955a875cb3e0f9693bd6d2c71
- https://github.com/serverpod/serverpod/security/advisories/GHSA-h6x7-r5rg-x5fw
- https://github.com/serverpod/serverpod/commit/d55bf8d12967fc7955a875cb3e0f9693bd6d2c71
- https://github.com/serverpod/serverpod/security/advisories/GHSA-h6x7-r5rg-x5fw
Get alerted when CVE-2024-29887 or the next vulnerability affects your stack