What’s Vulnerable › Vulnerabilities
CVE-2024-29889: GLPI contains an SQL injection through the saved searches
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 64.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a Free Asset and IT Management Software package. Prior to 10.0.15, an authenticated user can exploit a SQL injection vulnerability in the saved searches feature to alter another user account data take control of it. This vulnerability is fixed in 10.0.15.
Affected products
- glpi-project glpi: from 10.0.10 before 10.0.15 — fixed in 10.0.15
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/0a6b28be4c0f848106c60b554c703ec2e178d6c7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-8xvf-v6vv-r75g
- https://github.com/glpi-project/glpi/commit/0a6b28be4c0f848106c60b554c703ec2e178d6c7
- https://github.com/glpi-project/glpi/security/advisories/GHSA-8xvf-v6vv-r75g
Get alerted when CVE-2024-29889 or the next vulnerability affects your stack