What’s Vulnerable › Vulnerabilities
CVE-2024-29890: Remote code execution in datalens-ui
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
DataLens is a business intelligence and data visualization system. A specifically crafted request allowed the creation of a special chart type with the ability to pass custom javascript code that would later be executed in an unprotected sandbox on subsequent requests to that chart. The problem was fixed in the datalens-ui version `0.1449.0`. Restricting access to the API for creating or modifying charts (`/charts/api/charts/v1/`) would mitigate the issue.
Affected products
- Datalenstech Datalens: before 0.1449.0 — fixed in 0.1449.0
How to fix
Upgrade to a fixed version: Datalenstech Datalens 0.1449.0. Check the vendor advisory for mitigations.
References
- https://github.com/datalens-tech/datalens/security/advisories/GHSA-6278-2wvc-4p93
- https://github.com/datalens-tech/datalens/security/advisories/GHSA-6278-2wvc-4p93
Get alerted when CVE-2024-29890 or the next vulnerability affects your stack