What’s Vulnerable › Vulnerabilities
CVE-2024-29894: Cacti Cross-site Scripting vulnerability when using JavaScript based messaging API
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cacti provides an operational monitoring and fault management framework. Versions of Cacti prior to 1.2.27 contain a residual cross-site scripting vulnerability caused by an incomplete fix for CVE-2023-50250. `raise_message_javascript` from `lib/functions.php` now uses purify.js to fix CVE-2023-50250 (among others). However, it still generates the code out of unescaped PHP variables `$title` and `$header`. If those variables contain single quotes, they can be used to inject JavaScript code. An attacker exploiting this vulnerability could execute actions on behalf of other users. This ability to impersonate users could lead to unauthorized changes to settings. Version 1.2.27 fixes this issue.
Affected products
- cacti: before 1.2.27 — fixed in 1.2.27
- Fedoraproject Fedora: 39
How to fix
Upgrade to a fixed version: cacti 1.2.27. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/security/advisories/GHSA-grj5-8fcj-34gh
- https://github.com/Cacti/cacti/security/advisories/GHSA-xwqc-7jc4-xm73
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
- https://github.com/Cacti/cacti/security/advisories/GHSA-grj5-8fcj-34gh
- https://github.com/Cacti/cacti/security/advisories/GHSA-xwqc-7jc4-xm73
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
Get alerted when CVE-2024-29894 or the next vulnerability affects your stack