What’s Vulnerable › Vulnerabilities
CVE-2024-29901: @workos-inc/authkit-nextjs session replay vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-294
Description
The AuthKit library for Next.js provides helpers for authentication and session management using WorkOS & AuthKit with Next.js. A user can reuse an expired session by controlling the `x-workos-session` header. The vulnerability is patched in v0.4.2.
Affected products
- workos authkit-nextjs: before 0.4.2 — fixed in 0.4.2
How to fix
Upgrade to a fixed version: workos authkit-nextjs 0.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/workos/authkit-nextjs/commit/6c3f4f3179d66cbb15de3962792083ff3b244a01
- https://github.com/workos/authkit-nextjs/releases/tag/v0.4.2
- https://github.com/workos/authkit-nextjs/security/advisories/GHSA-35w3-6qhc-474v
- https://github.com/workos/authkit-nextjs/commit/6c3f4f3179d66cbb15de3962792083ff3b244a01
- https://github.com/workos/authkit-nextjs/releases/tag/v0.4.2
- https://github.com/workos/authkit-nextjs/security/advisories/GHSA-35w3-6qhc-474v
Get alerted when CVE-2024-29901 or the next vulnerability affects your stack