What’s Vulnerable › Vulnerabilities
CVE-2024-29926: WordPress WC Builder plugin <= 1.0.18 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HasThemes WC Builder allows Stored XSS.This issue affects WC Builder: from n/a through 1.0.18.
Affected products
- HasThemes WC Builder: before 1.0.19 — fixed in 1.0.19
How to fix
Upgrade to a fixed version: HasThemes WC Builder 1.0.19. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wc-builder/wordpress-wc-builder-plugin-1-0-18-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wc-builder/wordpress-wc-builder-plugin-1-0-18-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29926 or the next vulnerability affects your stack