What’s Vulnerable › Vulnerabilities
CVE-2024-29944
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-22 · updated 2026-06-17
- Weakness: CWE-830
Description
An attacker was able to inject an event handler into a privileged object that would allow arbitrary JavaScript execution in the parent process. Note: This vulnerability affects Desktop Firefox only, it does not affect mobile versions of Firefox. This vulnerability affects Firefox < 124.0.1 and Firefox ESR < 115.9.1.
Affected products
- Debian Linux: 10.0
- Mozilla Firefox: before 115.9.1; through 124.0.1 — fixed in 115.9.1
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.9.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/23/1
- https://bugzilla.mozilla.org/show_bug.cgi?id=1886852
- https://lists.debian.org/debian-lts-announce/2024/03/msg00028.html
- https://www.mozilla.org/security/advisories/mfsa2024-15/
- https://www.mozilla.org/security/advisories/mfsa2024-16/
- http://www.openwall.com/lists/oss-security/2024/03/23/1
- https://bugzilla.mozilla.org/show_bug.cgi?id=1886852
- https://lists.debian.org/debian-lts-announce/2024/03/msg00028.html
- https://www.mozilla.org/security/advisories/mfsa2024-15/
- https://www.mozilla.org/security/advisories/mfsa2024-16/
Get alerted when CVE-2024-29944 or the next vulnerability affects your stack