What’s Vulnerable › Vulnerabilities
CVE-2024-29950: Brocade SANnav before v2.3.1, v2.3.0a uses weak encryption
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-326
Description
The class FileTransfer implemented in Brocade SANnav before v2.3.1, v2.3.0a, uses the ssh-rsa signature scheme, which has a SHA-1 hash. The vulnerability could allow a remote, unauthenticated attacker to perform a man-in-the-middle attack.
Affected products
- Brocade SANnav: before 2.3.0a — fixed in 2.3.0a
How to fix
Upgrade to a fixed version: Brocade SANnav 2.3.0a. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/external/content/SecurityAdvisories/0/23236
- https://support.broadcom.com/external/content/SecurityAdvisories/0/23236
Get alerted when CVE-2024-29950 or the next vulnerability affects your stack