What’s Vulnerable › Vulnerabilities
CVE-2024-29955: Insertion of Sensitive Information into Brocade SANnav Log File
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-532
Description
A vulnerability in Brocade SANnav before v2.3.1 and v2.3.0a could allow a privileged user to print the SANnav encrypted key in PostgreSQL startup logs. This could provide attackers with an additional, less-protected path to acquiring the encryption key.
Affected products
- Brocade SANnav: before 2.3.0a — fixed in 2.3.0a
How to fix
Upgrade to a fixed version: Brocade SANnav 2.3.0a. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/external/content/SecurityAdvisories/0/23239
- https://support.broadcom.com/external/content/SecurityAdvisories/0/23239
Get alerted when CVE-2024-29955 or the next vulnerability affects your stack