What’s Vulnerable › Vulnerabilities
CVE-2024-29973
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-78
Description
** UNSUPPORTED WHEN ASSIGNED ** The command injection vulnerability in the “setCookie” parameter in Zyxel NAS326 firmware versions before V5.21(AAZF.17)C0 and NAS542 firmware versions before V5.21(ABAG.14)C0 could allow an unauthenticated attacker to execute some operating system (OS) commands by sending a crafted HTTP POST request.
Affected products
- Zyxel NAS326 firmware: before 5.21\(aazf.17\)c0 — fixed in 5.21\(aazf.17\)c0
- Zyxel NAS542 firmware: before 5.21\(abag.14\)c0 — fixed in 5.21\(abag.14\)c0
How to fix
Upgrade to a fixed version: Zyxel NAS326 firmware 5.21\(aazf.17\)c0; Zyxel NAS542 firmware 5.21\(abag.14\)c0. Check the vendor advisory for mitigations.
References
- https://outpost24.com/blog/zyxel-nas-critical-vulnerabilities/
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities-in-nas-products-06-04-2024
- https://outpost24.com/blog/zyxel-nas-critical-vulnerabilities/
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities-in-nas-products-06-04-2024
Get alerted when CVE-2024-29973 or the next vulnerability affects your stack