What’s Vulnerable › Vulnerabilities

CVE-2024-29977: Malicious remote can create arbitrary reactions on arbitrary posts

Description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly validate synced reactions, when shared channels are enabled, which allows a malicious remote to create arbitrary reactions on arbitrary posts

Affected products

How to fix

Upgrade to a fixed version: Mattermost App Framework 9.5.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-29977 or the next vulnerability affects your stack