What’s Vulnerable › Vulnerabilities
CVE-2024-30114: HCL Leap is affected by a cross-site scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Insufficient sanitization in HCL Leap allows client-side script injection in the authoring environment.
Affected products
- HCL Software HCL Leap: before 9.3.6 — fixed in 9.3.6
How to fix
Upgrade to a fixed version: HCL Software HCL Leap 9.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-30114 or the next vulnerability affects your stack