What’s Vulnerable › Vulnerabilities
CVE-2024-30165
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-28 · updated 2026-06-17
- Weakness: CWE-120
Description
Amazon AWS Client VPN before 3.9.1 on macOS has a buffer overflow that could potentially allow a local actor to execute arbitrary commands with elevated permissions, a different vulnerability than CVE-2024-30164.
Affected products
- Amazon Aws Client Vpn: before 3.9.1 — fixed in 3.9.1
How to fix
Upgrade to a fixed version: Amazon Aws Client Vpn 3.9.1. Check the vendor advisory for mitigations.
References
- https://docs.aws.amazon.com/vpn/latest/clientvpn-user/client-vpn-connect-macos.html
- https://docs.aws.amazon.com/vpn/latest/clientvpn-user/client-vpn-connect-macos.html
Get alerted when CVE-2024-30165 or the next vulnerability affects your stack