What’s Vulnerable › Vulnerabilities
CVE-2024-30166
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-121
Description
In Mbed TLS 3.3.0 through 3.5.2 before 3.6.0, a malicious client can cause information disclosure or a denial of service because of a stack buffer over-read (of less than 256 bytes) in a TLS 1.3 server via a TLS 3.1 ClientHello.
Affected products
- TrustedFirmware Mbed TLS: from 3.3.0 before 3.6.0 — fixed in 3.6.0
How to fix
Upgrade to a fixed version: TrustedFirmware Mbed TLS 3.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/Mbed-TLS/mbedtls/releases/tag/v3.6.0
- https://mbed-tls.readthedocs.io/en/latest/tech-updates/security-advisories/
- https://github.com/Mbed-TLS/mbedtls/releases/tag/v3.6.0
- https://mbed-tls.readthedocs.io/en/latest/tech-updates/security-advisories/
Get alerted when CVE-2024-30166 or the next vulnerability affects your stack