What’s Vulnerable › Vulnerabilities
CVE-2024-30182: WordPress HT Mega – Absolute Addons For Elementor plugin <= 2.4.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in DevItems HT Mega ht-mega-for-elementor.This issue affects HT Mega: from n/a through <= 2.4.3.
Affected products
- devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.4.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/ht-mega-for-elementor/vulnerability/wordpress-ht-mega-absolute-addons-for-elementor-plugin-2-4-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ht-mega-for-elementor/wordpress-ht-mega-absolute-addons-for-elementor-plugin-2-4-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-30182 or the next vulnerability affects your stack