What’s Vulnerable › Vulnerabilities
CVE-2024-3019: Pcp: exposure of the redis server backend allows remote command execution via pmproxy
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-668
Description
A flaw was found in PCP. The default pmproxy configuration exposes the Redis server backend to the local network, allowing remote command execution with the privileges of the Redis user. This issue can only be exploited when pmproxy is running. By default, pmproxy is not running and needs to be started manually. The pmproxy service is usually started from the 'Metrics settings' page of the Cockpit web interface. This flaw affects PCP versions 4.3.4 and newer.
Affected products
- Red Hat Enterprise Linux 8: all versions — fixed in 0:5.3.7-20.el8_10
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 0:5.0.2-8.el8_2
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:5.2.5-7.el8_4
- Red Hat Enterprise Linux 8.4 Telecommunications Update Service: all versions — fixed in 0:5.2.5-7.el8_4
- Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions: all versions — fixed in 0:5.2.5-7.el8_4
- Red Hat Enterprise Linux 8.6 Extended Update Support: all versions — fixed in 0:5.3.5-9.el8_6
- Red Hat Enterprise Linux 8.8 Extended Update Support: all versions — fixed in 0:5.3.7-18.el8_8
- Red Hat Enterprise Linux 9: all versions — fixed in 0:6.2.0-2.el9_4
- Red Hat Enterprise Linux 9.0 Extended Update Support: all versions — fixed in 0:5.3.5-9.el9_0
- Red Hat Enterprise Linux 9.2 Extended Update Support: all versions — fixed in 0:6.0.1-6.el9_2
How to fix
Upgrade to a fixed version: Red Hat Enterprise Linux 8 0:5.3.7-20.el8_10; Red Hat Enterprise Linux 8.2 Advanced Update Support 0:5.0.2-8.el8_2; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:5.2.5-7.el8_4; Red Hat Enterprise Linux 8.4 Telecommunications Update Service 0:5.2.5-7.el8_4; Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 0:5.2.5-7.el8_4; Red Hat Enterprise Linux 8.6 Extended Update Support 0:5.3.5-9.el8_6; Red Hat Enterprise Linux 8.8 Extended Update Support 0:5.3.7-18.el8_8; Red Hat Enterprise Linux 9 0:6.2.0-2.el9_4; Red Hat Enterprise Linux 9.0 Extended Update Support 0:5.3.5-9.el9_0; Red Hat Enterprise Linux 9.2 Extended Update Support 0:6.0.1-6.el9_2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2024:2566
- https://access.redhat.com/errata/RHSA-2024:3264
- https://access.redhat.com/errata/RHSA-2024:3321
- https://access.redhat.com/errata/RHSA-2024:3322
- https://access.redhat.com/errata/RHSA-2024:3323
- https://access.redhat.com/errata/RHSA-2024:3324
- https://access.redhat.com/errata/RHSA-2024:3325
- https://access.redhat.com/errata/RHSA-2024:3392
- https://access.redhat.com/security/cve/CVE-2024-3019
- https://bugzilla.redhat.com/show_bug.cgi?id=2271898
- https://access.redhat.com/errata/RHSA-2024:2566
- https://access.redhat.com/errata/RHSA-2024:3264
Get alerted when CVE-2024-3019 or the next vulnerability affects your stack