What’s Vulnerable › Vulnerabilities
CVE-2024-30192: WordPress Pinterest Plugin <= 1.8.2 - Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GS Plugins GS Pins for Pinterest allows Stored XSS.This issue affects GS Pins for Pinterest: from n/a through 1.8.2.
Affected products
- GS Plugins GS Pins for Pinterest: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: GS Plugins GS Pins for Pinterest 1.8.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/gs-pinterest-portfolio/wordpress-pinterest-plugin-1-8-2-cross-site-scripting-xss?_s_id=cve
- https://patchstack.com/database/vulnerability/gs-pinterest-portfolio/wordpress-pinterest-plugin-1-8-2-cross-site-scripting-xss?_s_id=cve
Get alerted when CVE-2024-30192 or the next vulnerability affects your stack