What’s Vulnerable › Vulnerabilities
CVE-2024-3020: Carousel, Slider, Gallery by WP Carousel – Image Carousel & Photo Gallery, Post Carousel & Post Grid, Product Carousel & Product Grid for WooCommerce <= 2.6.3 - Authenticated (Admin+) PHP Object Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-502
Description
The plugin is vulnerable to PHP Object Injection in versions up to and including, 2.6.3 via deserialization of untrusted input in the import function via the 'shortcode' parameter. This allows authenticated attackers, with administrator-level access to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- Logo Carousel – Logo Slider, Logo Showcase, and Clients Logo Gallery: before 2.6.3 — fixed in 2.6.3
- shapedplugin Post Grid, Post Carousel, & List Category Posts: before 2.6.3 — fixed in 2.6.3
- Product Slider for WooCommerce: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: Logo Carousel – Logo Slider, Logo Showcase, and Clients Logo Gallery 2.6.3; shapedplugin Post Grid, Post Carousel, & List Category Posts 2.6.3; Product Slider for WooCommerce 2.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3065296/wp-carousel-free/trunk/includes/class-wp-carousel-free-import-export.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d66df15e-1a0a-49e9-bcf9-67091499b24e?source=cve
- https://plugins.trac.wordpress.org/changeset/3065296/wp-carousel-free/trunk/includes/class-wp-carousel-free-import-export.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d66df15e-1a0a-49e9-bcf9-67091499b24e?source=cve
Get alerted when CVE-2024-3020 or the next vulnerability affects your stack