What’s Vulnerable › Vulnerabilities
CVE-2024-30204
- Severity: low (CVSS 2.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-276
Description
In Emacs before 29.3, LaTeX preview is enabled by default for e-mail attachments.
Affected products
- Debian Linux: 10.0
- GNU Emacs: before 29.3 — fixed in 29.3
- GNU Org Mode: before 9.6.23 — fixed in 9.6.23
How to fix
Upgrade to a fixed version: GNU Emacs 29.3; GNU Org Mode 9.6.23. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/25/2
- http://www.openwall.com/lists/oss-security/2024/04/08/3
- http://www.openwall.com/lists/oss-security/2024/04/08/4
- http://www.openwall.com/lists/oss-security/2024/04/08/6
- http://www.openwall.com/lists/oss-security/2024/04/08/7
- http://www.openwall.com/lists/oss-security/2024/04/10/3
- http://www.openwall.com/lists/oss-security/2024/04/10/4
- http://www.openwall.com/lists/oss-security/2024/04/10/5
- http://www.openwall.com/lists/oss-security/2024/04/10/6
- http://www.openwall.com/lists/oss-security/2024/04/11/4
- https://git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-29&id=6f9ea396f49cbe38c2173e0a72ba6af3e03b271c
- https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-29
Get alerted when CVE-2024-30204 or the next vulnerability affects your stack