What’s Vulnerable › Vulnerabilities
CVE-2024-30226: WordPress BetterDocs plugin <= 3.3.3 - Unauthenticated PHP Object Injection vulnerability
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in WPDeveloper BetterDocs.This issue affects BetterDocs: from n/a through 3.3.3.
Affected products
- WPDeveloper BetterDocs: before 3.3.4 — fixed in 3.3.4
How to fix
Upgrade to a fixed version: WPDeveloper BetterDocs 3.3.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/betterdocs/wordpress-betterdocs-plugin-3-3-3-unauthenticated-php-object-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/betterdocs/wordpress-betterdocs-plugin-3-3-3-unauthenticated-php-object-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-30226 or the next vulnerability affects your stack