What’s Vulnerable › Vulnerabilities
CVE-2024-30235: WordPress Multiple Page Generator Plugin – MPG plugin <= 3.4.0 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-26 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in Themeisle Multiple Page Generator Plugin – MPG.This issue affects Multiple Page Generator Plugin – MPG: from n/a through 3.4.0.
Affected products
- themeisle Multiple Page Generator Plugin – MPG: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: themeisle Multiple Page Generator Plugin – MPG 3.4.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/multiple-pages-generator-by-porthas/wordpress-multiple-page-generator-plugin-mpg-plugin-3-4-0-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/multiple-pages-generator-by-porthas/wordpress-multiple-page-generator-plugin-mpg-plugin-3-4-0-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-30235 or the next vulnerability affects your stack