What’s Vulnerable › Vulnerabilities
CVE-2024-30247: Command Injection as root in NextCloudPi web panel
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-78
Description
NextcloudPi is a ready to use image for Virtual Machines, Raspberry Pi, Odroid HC1, Rock64 and other boards. A command injection vulnerability in NextCloudPi allows command execution as the root user via the NextCloudPi web-panel. Due to a security misconfiguration this can be used by anyone with access to NextCloudPi web-panel, no authentication is required. It is recommended that the NextCloudPi is upgraded to 1.53.1.
Affected products
- nextcloudpi: before 1.53.1 — fixed in 1.53.1
How to fix
Upgrade to a fixed version: nextcloudpi 1.53.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/nextcloudpi/security/advisories/GHSA-m597-72v7-j982
- https://github.com/nextcloud/nextcloudpi/security/advisories/GHSA-m597-72v7-j982
Get alerted when CVE-2024-30247 or the next vulnerability affects your stack