What’s Vulnerable › Vulnerabilities
CVE-2024-30251: Denial of service when trying to parse malformed POST requests in aiohttp
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-835
Description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. In affected versions an attacker can send a specially crafted POST (multipart/form-data) request. When the aiohttp server processes it, the server will enter an infinite loop and be unable to process any further requests. An attacker can stop the application from serving requests after sending a single request. This issue has been addressed in version 3.9.4. Users are advised to upgrade. Users unable to upgrade may manually apply a patch to their systems. Please see the linked GHSA for instructions.
Affected products
- aio-libs aiohttp: before 3.9.4 — fixed in 3.9.4
- Pypi Aiohttp: before 3.9.4; 0.1, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0 (+223) — fixed in 3.9.4
How to fix
Upgrade to a fixed version: aio-libs aiohttp 3.9.4; Pypi Aiohttp 3.9.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/05/02/4
- https://github.com/aio-libs/aiohttp/commit/7eecdff163ccf029fbb1ddc9de4169d4aaeb6597
- https://github.com/aio-libs/aiohttp/commit/cebe526b9c34dc3a3da9140409db63014bc4cf19
- https://github.com/aio-libs/aiohttp/commit/f21c6f2ca512a026ce7f0f6c6311f62d6a638866
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-5m98-qgg9-wh84
- http://www.openwall.com/lists/oss-security/2024/05/02/4
- https://github.com/aio-libs/aiohttp/commit/7eecdff163ccf029fbb1ddc9de4169d4aaeb6597
- https://github.com/aio-libs/aiohttp/commit/cebe526b9c34dc3a3da9140409db63014bc4cf19
- https://github.com/aio-libs/aiohttp/commit/f21c6f2ca512a026ce7f0f6c6311f62d6a638866
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-5m98-qgg9-wh84
- https://lists.debian.org/debian-lts-announce/2025/02/msg00002.html
Get alerted when CVE-2024-30251 or the next vulnerability affects your stack