What’s Vulnerable › Vulnerabilities
CVE-2024-30255: HTTP/2: CPU exhaustion due to CONTINUATION frame flood
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-390
Description
Envoy is a cloud-native, open source edge and service proxy. The HTTP/2 protocol stack in Envoy versions prior to 1.29.3, 1.28.2, 1.27.4, and 1.26.8 are vulnerable to CPU exhaustion due to flood of CONTINUATION frames. Envoy's HTTP/2 codec allows the client to send an unlimited number of CONTINUATION frames even after exceeding Envoy's header map limits. This allows an attacker to send a sequence of CONTINUATION frames without the END_HEADERS bit set causing CPU utilization, consuming approximately 1 core per 300Mbit/s of traffic and culminating in denial of service through CPU exhaustion. Users should upgrade to version 1.29.3, 1.28.2, 1.27.4, or 1.26.8 to mitigate the effects of the CONTINUATION flood. As a workaround, disable HTTP/2 protocol for downstream connections.
Affected products
- envoyproxy envoy: before 1.26.8; from 1.27.0 before 1.27.4; from 1.28.0 before 1.28.2; from 1.29.0 before 1.29.3 — fixed in 1.26.8, 1.27.4, 1.28.2, 1.29.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.26.8, 1.27.4, 1.28.2, 1.29.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/03/16
- http://www.openwall.com/lists/oss-security/2024/04/05/3
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-j654-3ccm-vfmm
- http://www.openwall.com/lists/oss-security/2024/04/03/16
- http://www.openwall.com/lists/oss-security/2024/04/05/3
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-j654-3ccm-vfmm
- https://www.kb.cert.org/vuls/id/421644
Get alerted when CVE-2024-30255 or the next vulnerability affects your stack