What’s Vulnerable › Vulnerabilities
CVE-2024-30258: FastDDS crash when publisher send malformed packet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-20
Description
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves a malformed `RTPS` packet, the subscriber crashes when creating `pthread`. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
Affected products
- eProsima Fast-DDS: before 2.6.8; from 2.10.0 before 2.10.4; from 2.13.0 before 2.13.5; 2.14.0 — fixed in 2.10.4, 2.13.5, 2.6.8
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.10.4, 2.13.5, 2.6.8. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/19W5UC52hPnAqVq_boZWO45d1TJ4WoCSh/view?usp=sharing
- https://github.com/eProsima/Fast-DDS/commit/65236f93e9c4ea3ff9a49fba4dfd9e43eb94037b
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-53xw-465j-rxfh
- https://drive.google.com/file/d/19W5UC52hPnAqVq_boZWO45d1TJ4WoCSh/view?usp=sharing
- https://github.com/eProsima/Fast-DDS/commit/65236f93e9c4ea3ff9a49fba4dfd9e43eb94037b
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-53xw-465j-rxfh
Get alerted when CVE-2024-30258 or the next vulnerability affects your stack