What’s Vulnerable › Vulnerabilities
CVE-2024-30259: FastDDS heap buffer overflow when publisher sends malformed packet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-120
Description
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed `RTPS` packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
Affected products
- eProsima Fast-DDS: before 2.6.8; from 2.10.0 before 2.10.4; from 2.13.0 before 2.13.5; 2.14.0 — fixed in 2.10.4, 2.13.5, 2.6.8
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.10.4, 2.13.5, 2.6.8. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1Y2bGvP3UIOJCLh_XEURLdhrM2Sznlvlp/view?usp=sharing
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-qcj9-939p-p662
- https://vimeo.com/907641887?share=copy
- https://drive.google.com/file/d/1Y2bGvP3UIOJCLh_XEURLdhrM2Sznlvlp/view?usp=sharing
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-qcj9-939p-p662
- https://vimeo.com/907641887?share=copy
Get alerted when CVE-2024-30259 or the next vulnerability affects your stack