What’s Vulnerable › Vulnerabilities
CVE-2024-3026: WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Button Plugin MaxButtons WordPress plugin before 9.7.8 does not sanitise and escape some parameters, which could allow users with a role as low as editor to perform Cross-Site Scripting attacks
Affected products
- maxfoundry MaxButtons – Create buttons: before 9.7.8 — fixed in 9.7.8
How to fix
Upgrade to a fixed version: maxfoundry MaxButtons – Create buttons 9.7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aba9d8a5-20a7-49e5-841c-9cfcb9bc6144/
- https://wpscan.com/vulnerability/aba9d8a5-20a7-49e5-841c-9cfcb9bc6144/
Get alerted when CVE-2024-3026 or the next vulnerability affects your stack