What’s Vulnerable › Vulnerabilities

CVE-2024-30271: Adobe Illustrator 2023 CC 27.7 Memory Corruption Out-Of-Bounds-Write Vulnerability III.

Description

Illustrator versions 28.3, 27.9.2 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 27.9.3, 28.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-30271 or the next vulnerability affects your stack