What’s Vulnerable › Vulnerabilities
CVE-2024-30273: Adobe Illustrator 2024 PS file Parsing Stack based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-121
Description
Illustrator versions 28.3, 27.9.2 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: before 27.9.3; from 28.0 before 28.4 — fixed in 27.9.3, 28.4
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.9.3, 28.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb24-25.html
- https://helpx.adobe.com/security/products/illustrator/apsb24-25.html
Get alerted when CVE-2024-30273 or the next vulnerability affects your stack