What’s Vulnerable › Vulnerabilities
CVE-2024-3028: Improper Input Validation in mintplex-labs/anything-llm
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-20
Description
mintplex-labs/anything-llm is vulnerable to improper input validation, allowing attackers to read and delete arbitrary files on the server. By manipulating the 'logo_filename' parameter in the 'system-preferences' API endpoint, an attacker can construct requests to read sensitive files or the application's '.env' file, and even delete files by setting the 'logo_filename' to the path of the target file and invoking the 'remove-logo' API endpoint. This vulnerability is due to the lack of proper sanitization of user-supplied input.
Affected products
- Mintplexlabs Anythingllm: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/7de23dbb2da932fbfb39f56d981784d3702cf5ce
- https://huntr.com/bounties/41016b86-eabb-4161-ac81-40a1ca8e82ac
- https://github.com/mintplex-labs/anything-llm/commit/7de23dbb2da932fbfb39f56d981784d3702cf5ce
- https://huntr.com/bounties/41016b86-eabb-4161-ac81-40a1ca8e82ac
Get alerted when CVE-2024-3028 or the next vulnerability affects your stack