What’s Vulnerable › Vulnerabilities
CVE-2024-30290: Adobe FrameMaker WEBP File Parsing Out Of Bound Write
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Framemaker versions 2020.5, 2022.3 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: before 2020.6; from 2022 before 2022.4 — fixed in 2020.6, 2022.4
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.6, 2022.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/framemaker/apsb24-37.html
- https://helpx.adobe.com/security/products/framemaker/apsb24-37.html
Get alerted when CVE-2024-30290 or the next vulnerability affects your stack