What’s Vulnerable › Vulnerabilities
CVE-2024-30306: ZDI-CAN-23106: Adobe Acrobat Reader DC AcroForm Out-Of-Bounds Read Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-125
Description
Acrobat Reader versions 20.005.30539, 23.008.20470 and earlier are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to execute code in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30002 before 20.005.30574 — fixed in 20.005.30574
- Adobe Acrobat DC: from 15.007.20033 before 23.008.20533 — fixed in 23.008.20533
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30574 — fixed in 20.005.30574
- Adobe Acrobat Reader: from 15.007.20033 before 23.008.20533 — fixed in 23.008.20533
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30574; Adobe Acrobat DC 23.008.20533; Adobe Acrobat Reader 20.005.30574; Adobe Acrobat Reader 23.008.20533. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb24-07.html
- https://helpx.adobe.com/security/products/acrobat/apsb24-07.html
Get alerted when CVE-2024-30306 or the next vulnerability affects your stack