What’s Vulnerable › Vulnerabilities
CVE-2024-30314: Dreamweaver Desktop | Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') (CWE-78)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-78
Description
Dreamweaver Desktop versions 21.3 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an attacker. Exploitation of this issue does require user interaction.
Affected products
- Adobe Dreamweaver Desktop: before 21.4 — fixed in 21.4
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/dreamweaver/apsb24-39.html
- https://helpx.adobe.com/security/products/dreamweaver/apsb24-39.html
Get alerted when CVE-2024-30314 or the next vulnerability affects your stack