What’s Vulnerable › Vulnerabilities
CVE-2024-30331: Foxit PDF Reader AcroForm Use-After-Free Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Foxit PDF Reader AcroForm Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of Doc objects in AcroForms. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22637.
Affected products
- Foxit PDF Reader: before 11.1.6.0109; from 12.0.0.0601 before 12.1.2.55366; from 13.0.0.61829 before 13.0.1.61866; from 2023.1.0.55583 before 2023.3.0.63083; before 10.1.12.37872; from 11.0.0.49893 before 11.2.8.53842 — fixed in 10.1.12.37872, 11.1.6.0109, 11.2.8.53842, 12.1.2.55366, 12.1.4.15400, 13.0.1.21693
- Foxit Pdf Reader: before 2023.3.0.63083; before 2023.3.0.23028 — fixed in 2023.3.0.23028, 2023.3.0.63083
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.12.37872, 11.1.6.0109, 11.2.8.53842, 12.1.2.55366; Foxit Pdf Reader 2023.3.0.23028, 2023.3.0.63083. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-308/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-308/
Get alerted when CVE-2024-30331 or the next vulnerability affects your stack