What’s Vulnerable › Vulnerabilities
CVE-2024-30341: Foxit PDF Reader Doc Object Out-Of-Bounds Read Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-125
Description
Foxit PDF Reader Doc Object Out-Of-Bounds Read Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of Doc objects. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22709.
Affected products
- Foxit PDF Reader: through 10.1.12.37872; from 11.0.0 before 11.2.8.53842; from 12.0.0 before 12.1.4.15400; from 13.0.0 before 13.0.1.21693; from 2023.1.0.15510 through 2023.3.0.23028 — fixed in 11.2.8.53842, 12.1.4.15400, 13.0.1.21693
- Foxit Pdf Reader: before 2023.3.0.23028 — fixed in 2023.3.0.23028
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.2.8.53842, 12.1.4.15400, 13.0.1.21693; Foxit Pdf Reader 2023.3.0.23028. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-315/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-315/
Get alerted when CVE-2024-30341 or the next vulnerability affects your stack