What’s Vulnerable › Vulnerabilities
CVE-2024-30394: Junos OS and Junos OS Evolved: A specific EVPN type-5 route causes rpd crash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-12 · updated 2026-06-17
- Weakness: CWE-121
Description
A Stack-based Buffer Overflow vulnerability in the Routing Protocol Daemon (RPD) component of Junos OS and Junos OS Evolved allows an unauthenticated, network-based attacker to cause an rpd crash, leading to Denial of Service (DoS). On all Junos OS and Junos OS Evolved platforms, when EVPN is configured, and a specific EVPN type-5 route is received via BGP, rpd crashes and restarts. Continuous receipt of this specific route will lead to a sustained Denial of Service (DoS) condition. This issue affects: Junos OS: * all versions before 21.2R3-S7, * from 21.4 before 21.4R3-S5, * from 22.1 before 22.1R3-S4, * from 22.2 before 22.2R3-S2, * from 22.3 before 22.3R3-S1, * from 22.4 before 22.4R3, * from 23.2 before 23.2R2. Junos OS Evolved: * all versions before 21.4R3-S5-EVO, * from 22.1-EVO before 22.1R3-S4-EVO, * from 22.2-EVO before 22.2R3-S2-EVO, * from 22.3-EVO before 22.3R3-S1-EVO, * from 22.4-EVO before 22.4R3-EVO, * from 23.2-EVO before 23.2R2-EVO.
Affected products
- Juniper Junos OS: before 21.2; 21.2, 21.2-r1, 21.2-r1-s1, 21.2-r1-s2, 21.2-r2, 21.2-r2-s1 (+59) — fixed in 21.2
- Juniper Networks Junos OS Evolved: before 21.4; 21.4, 21.4-r1, 21.4-r1-s1, 21.4-r1-s2, 21.4-r2, 21.4-r2-s1 (+44) — fixed in 21.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 21.2; Juniper Networks Junos OS Evolved 21.4. Check the vendor advisory for mitigations.
References
- https://supportportal.juniper.net/JSA79094
- https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L
- https://supportportal.juniper.net/JSA79094
- https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L
Get alerted when CVE-2024-30394 or the next vulnerability affects your stack