What’s Vulnerable › Vulnerabilities
CVE-2024-30420
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-side request forgery (SSRF) vulnerability exists in a-blog cms Ver.3.1.x series versions prior to Ver.3.1.12 and Ver.3.0.x series versions prior to Ver.3.0.32. If this vulnerability is exploited, a user with an administrator or higher privilege who can log in to the product may obtain arbitrary files on the server and information on the internal server that is not disclosed to the public.
Affected products
- appleple inc. a-blog cms: from 3.0.0 before 3.0.32; from 3.1.0 before 3.1.12 — fixed in 3.0.32, 3.1.12
How to fix
Upgrade to a fixed version: appleple inc. a-blog cms 3.0.32, 3.1.12. Check the vendor advisory for mitigations.
References
- https://developer.a-blogcms.jp/blog/news/JVN-70977403.html
- https://jvn.jp/en/jp/JVN70977403/
- https://developer.a-blogcms.jp/blog/news/JVN-70977403.html
- https://jvn.jp/en/jp/JVN70977403/
Get alerted when CVE-2024-30420 or the next vulnerability affects your stack