What’s Vulnerable › Vulnerabilities
CVE-2024-30429: WordPress wp-forecast plugin <= 9.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Hans Matzen allows Stored XSS.This issue affects wp-forecast: from n/a through 9.2.
Affected products
- Hans Matzen wp-forecast: before 9.3 — fixed in 9.3
How to fix
Upgrade to a fixed version: Hans Matzen wp-forecast 9.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-forecast/wordpress-wp-forecast-plugin-9-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-forecast/wordpress-wp-forecast-plugin-9-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-30429 or the next vulnerability affects your stack