What’s Vulnerable › Vulnerabilities
CVE-2024-30442: WordPress Bold Page Builder plugin <= 4.8.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BoldThemes Bold Page Builder allows Stored XSS.This issue affects Bold Page Builder: from n/a through 4.8.0.
Affected products
- boldthemes Bold Page Builder: before 4.8.1 — fixed in 4.8.1
How to fix
Upgrade to a fixed version: boldthemes Bold Page Builder 4.8.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bold-page-builder/wordpress-bold-page-builder-plugin-4-8-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/bold-page-builder/wordpress-bold-page-builder-plugin-4-8-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-30442 or the next vulnerability affects your stack